PHP

PHP Mail:使用纯文本和HTML格式发送Email(多部分消息)

使用PHP Mail发送邮件,可以选择纯文本格式或者HTML格式,HTML格式更加吸引眼球因此应用越来越广泛,但使用HTML格式有一定的劣势[1],在发送HTML格式的邮件时最好同时发送纯文本格式,这样使用不支持HTML的旧式电子邮件客户端的用户依然可以读取邮件内容。这里用到的方法叫多部分消息。

Read More
WordPress

WordPress Sidebar命名问题

一直以为wordpress的sidebar名字可以随便起,原来不行!类似Sidebar 1,、Sidebar 2的名字要慎用,如果一定要用,那必须是在确认这几个sidebar在顺序上确实是第一个、第二个。。。,否则即使指定了id,也没用!

如果代码是这样

register_sidebar( array(
		'name' => __( 'Sidebar 1', 'twentyeleven' ),
		'before_widget' => '


",
		'before_title' => '

', 'after_title' => '

', ) );

而Sidebar 1并不是第一个Sidebar,就会出现问题,假设第一个sidebar叫Top Sidebar,那就会出现Top Sidebar和Sidebar 1内容相同的情况

Read More
WordPress

NextGen Gallery 自定义模板

NextGen Gallery从1.00版开始支持模板引擎系统,用户可以定制自己的模板,用户自定义的模板优先级高于插件默认的模板。自定义模板的好处不用多说,NexGen提供给我们很多有用的数据,如何安排将由我们来决定。

修改album模板

在当前主题目录下创建一个目录名为nggallery,自定义的模板放在该目录下,NextGen Gallery总是先到该目录下寻找用户自定义模板,如果没有找到再调用默认模板。

Read More
Javascript

最简单的jquery页内锚点平滑跳转代码

通过jQuery实现页面内锚点平滑跳转的方法很多,可以通过插件实现,也可以简单的通过animate方法实现,下面介绍比较简单的方法。

代码只有一句话

$("html,body").animate({scrollTop: $("#elementid").offset().top}, 1000);

animate()方法用来实现一组css的自定义动画,有两种调用方法

Read More
WordPress

WordPress提示Chrome版本过低

今天一进WordPress后台,诧异了,居然提示我“您的浏览器版本很低,似乎您正在使用旧版本的Chrome”。这后台真给力,不仅针对低版本的IE6和IE7,其它浏览器版本不是最新的都提示么。昨天用firefox 8进入也得到了相同的提示,于是升级到firefox 9.

浏览器还没提示更新,wordpress后台就提示了,没办法点了About Google Chrome开始更新之。。。

Read More
WordPress

How To Remove “Warning: Suspected phishing site”

Firefox和Chrome浏览器都具备防欺诈网站过滤器的功能。google除了有malware list,还有一个phishing list(钓鱼网站列表)。注意这两个列表是不同的。如果你的网站被黑,有恶意代码,那么google搜索结果中会提示该网站含有恶意代码等等,如果被列入phishing list,搜索结果里不会有提示,但用户通过Firefox或者Chrome访问网站时会提示Warning: Suspected phishing site

Read More
其他

WordPress后台错误:editPermalink is not defined

WordPress后台出错了,编辑文章面板里很多按钮不能用,包括编辑固定连接,右侧修改状态、公开度等编辑按钮。以前在wordpress论坛听到有人问过,当时还想是浏览器问题,这下让自己给撞上了。

Read More